Dentsply Q50 oven-vacuum on/off intermittent

victormasi

victormasi

Active Member
Full Member
Messages
126
Reaction score
29
Hi All

I have Q50 oven that I use all day long, working great but for the vacuum pump which keeps turning on-off constantly during fire cycle. If I change the vacuum setting to 101% pull it runs non-stop but solves the on-off cycle issue. Does anyone know what part is needed to solve the problem? Seems like a vac. leak somewhere.
Thanks in advance.
 

Attachments

  • Dentsply-Ceramco-Ney-Centurion-Q50-Dental-Oven.jpg
    Dentsply-Ceramco-Ney-Centurion-Q50-Dental-Oven.jpg
    18.7 KB · Views: 0
TheLabGuy

TheLabGuy

Just a Member
Full Member
Messages
5,716
Reaction score
817
Yep, i had the same problem, I called Dentsply Repair (took a minute to get threw all the auto-prompts) but once I was able to speak to a human in that department they knew exactly what it was, the part #, and told me how to replace it over the phone. I did and mine is still going...I swear you can't kill these Q50's.
 
victormasi

victormasi

Active Member
Full Member
Messages
126
Reaction score
29
Thanks for the quick reply. Do you by chance have the contact name/number of who helped you?
 
TheLabGuy

TheLabGuy

Just a Member
Full Member
Messages
5,716
Reaction score
817
Thanks for the quick reply. Do you by chance have the contact name/number of who helped you?
I don't, but just call Dentsply and talk to someone in Repair Department they will tell you everything to get you up and running.
 

Similar threads

Top Bottom