• Welcome to Dental Lab Network
    1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

    First Lisi press.....ummm yuk

    Discussion in 'All Porcelain-Press' started by sndmn2, Dec 16, 2016.

    1. sndmn2

      sndmn2 Active Member Full Member

      Joined:
      Apr 2010
      Messages:
      368
      Likes Received:
      53
      So I did my first Lisi press. Two separate molars A1 and A2 .. I used MT pellets for both. Press temp of 915c. and a 15 minute hold. Both crowns look as though were pressed out of a gray enamel pellet to me. No dentin coloring at all. Also, big demarcation line that looks like a crack.. Any thoughts on where I went wrong with the firing ? Thanks..
       
    2. kmart

      kmart New Member Full Member

      Joined:
      Dec 2013
      Messages:
      28
      Likes Received:
      12
      What size ring are you using?
       
    3. sndmn2

      sndmn2 Active Member Full Member

      Joined:
      Apr 2010
      Messages:
      368
      Likes Received:
      53
      Small = 100g.
       
    4. Affinity
      Question

      Affinity Well-Known Member Full Member

      Joined:
      Oct 2009
      Messages:
      3,405
      Likes Received:
      602
      915 is too high, they are recommending 897c @ 65c/min Probably overfired. Ive only pressed one ring, mta2, at 899.. looked nice. Pressing a HT59 now for a C1 for 8,9 and a D2 premolar... The ingot looks very nice compared to the guide.. should be a slight chroma firing/glaze and out the door..
       
    5. sndmn2

      sndmn2 Active Member Full Member

      Joined:
      Apr 2010
      Messages:
      368
      Likes Received:
      53
      Just checked instructions. The 200 gram at 213 c. for some reason stuck in my mind which is just 2 less than my EP5000 was already set for .
       

    Share This Page